题目描述

成绩统计。输入 N 个学生的姓名和语文、数学成绩,按总分从高到低排序输出。分数相同按输入先后输出。

输入输出

输入格式:
第1行,有一个整数N,N的范围是[1…100];
下面有N行,每行一个姓名,2个整数。
姓名由不超过10个的小写字母组成,整数范围是[0…100]。
输出格式:
总分排序后的名单,共N行,每行格式:姓名 语文 数学 总分。
输入样例:

4
gaoxiang  78 96
wangxi  70 99
liujia  90 87
zhangjin  78 91

输出样例:

liujia  90 87 177
gaoxiang  78 96 174
wangxi  70 99 169
zhangjin  78 91 169

问题分析

由于姓名是字符串,分数是整数,
如果用数组保存,则要两个数组,比如:

string name[100];
int score[100][3];

这种方法不利于把一个学生的信息当成一个整体处理。
下面程序中通过使用结构(struct)类型的方法来解决这个问题。

代码示例

#include <iostream>
#include <cstring>
using namespace std;

//================定义结构体================
struct tStudent
{
    string name;
    int chinese,math,sum;
};

tStudent people[100];
int n;

int main()
{
    cin>>n;
    //================输入数据================
    for(int i=0;i<n;i++)
    {
        cin>>people[i].name>>people[i].chinese>>people[i].math;
        people[i].sum = people[i].math + people[i].chinese;
    }
    //================冒泡排序================
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n-i+1;j++)
        {
            if(people[j].sum < people[j+1].sum)
            {
                swap(people[j],people[j+1]);
            }
        }
    }
    //================输出================
    for(int i=0;i<n;i++)
    {
        cout<<people[i].name<<" "<<people[i].chinese<<" "<<people[i].math<<" "<<people[i].sum<<endl;
    }
    return 0;
}
最后修改:2021 年 04 月 09 日
赠人玫瑰,手有余香。您的赞赏是对我最大的支持!